Discussion:
Battery charger question
Add Reply
M***@_._
2008-04-06 15:27:46 UTC
Reply
Permalink
Raw Message
I have a Schumacher Speed Charge SC-7500A battery charger.
I put it on my Mustang yesterday.

It keeps "locking up" with 88.8 displayed.

I can't find the manual.
Anyone know what's happening?
Mark Lloyd
2008-04-06 16:16:34 UTC
Reply
Permalink
Raw Message
Post by M***@_._
I have a Schumacher Speed Charge SC-7500A battery charger.
I put it on my Mustang yesterday.
It keeps "locking up" with 88.8 displayed.
I can't find the manual.
Not even on their website? Many companies have them there.
Post by M***@_._
Anyone know what's happening?
88.8 sounds like testing the display (all segments lit). However, it
shouldn't stay that way more than a couple of seconds on startup.

Are you sure it's connected right?

I don't have that model, but one battery charger I have refuses to
work when the battery charge is too low.
--
Mark Lloyd
http://notstupid.laughingsquid.com

"So far as I can remember, there is not one word
in the Gospels in praise of intelligence."
--Bertrand Russell
Tim
2008-04-06 16:20:22 UTC
Reply
Permalink
Raw Message
Post by M***@_._
I have a Schumacher Speed Charge SC-7500A battery charger.
I put it on my Mustang yesterday.
It keeps "locking up" with 88.8 displayed.
I can't find the manual.
Anyone know what's happening?
Well, the manuals are here;

http://www.schumacherproducts.com/manuals


However, a search of "88" showed no finds. I would be inclined
to believe the digital readout is stuck. Have you tried
unplugging the unit a few times to see if it will clear the
registers? It reminds of when you see digital readouts where
the LED part has burned away; but yours are stuck in full
readout. *8* being the full circle of LED's.

Tim
M***@_._
2008-04-06 17:17:15 UTC
Reply
Permalink
Raw Message
Post by Tim
http://www.schumacherproducts.com/manuals
Ah, thanks.
Post by Tim
However, a search of "88" showed no finds. I would be inclined
to believe the digital readout is stuck.
No, the whole unit is locked up. You have to unplug it and plug it
back in, then it resumes. It's up to 70% charge now.

I've used the charger several times before and never had this happen.
I hope my battery isn't done for. I just spent $500 on a new
alternator and another $100 on a new battery for my Explorer.

I usually put a battery tender on my Mustang in the Fall...just forgot
this time. Funny, considering I washed it, filled it up, put fuel
stabilizer in it....
Max
2018-05-17 04:14:01 UTC
Reply
Permalink
Raw Message
replying to Mitch, Max wrote:
Mitch, you had a sulfated battery. Its explained in the user manual. That's
the code it will display in such a case

--
for full context, visit https://www.homeownershub.com/maintenance/battery-charger-question-298295-.htm
t***@mucks.net
2008-04-06 17:06:05 UTC
Reply
Permalink
Raw Message
Post by M***@_._
I have a Schumacher Speed Charge SC-7500A battery charger.
I put it on my Mustang yesterday.
It keeps "locking up" with 88.8 displayed.
I can't find the manual.
Anyone know what's happening?
One of these will be your manual

http://manuals.batterychargers.com/manuals/00-99-000621.pdf

http://manuals.batterychargers.com/manuals/00-99-000657.pdf
Loading...